Kodiak 400 Dies on Engine Braking - Grizzly Riders - Yamaha Grizzly ATV Forum

Grizzly Talk Talk about everything else Grizzly related here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-31-2019, 12:13 AM Thread Starter
New Member
 
Join Date: Oct 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Kodiak 400 Dies on Engine Braking

I have a 2003 Kodiak 400 that I’m thinking of handing down to my son. I’ve been eyeing a new Grizzly, and I just need a push,
Anyway, last weekend, I let my son ride the 400 to see if he was interested, while I suffered on an old Suzuki LT125. Still recovering. He stopped along the trail a dozen times saying when the 400 was engine braking, it would just die. After stopping, he’d tap the starter button, and it’d fire right up. I just rebuilt the carb last year, and it runs and starts up perfectly. Even cold, tap the starter and it fires. But, this dying issue seems weird. I rode it several times and it’d never die for me, but soon enough after, my son would be pulling over again, saying it just died when engine braking when he let off the gas.
Any thoughts on this? My son said a couple times it backfired and popped, but I never witnessed that either. My dad was with, and witnessed every time it died. I can’t figure it out.
BruinBob is offline  
Reply

Bookmarks

Tags
400, braking, dies, engine, kodiak

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Grizzly Riders - Yamaha Grizzly ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome